WAP手机版 保存到桌面加入收藏设为首页
易语言源码
当前位置:首页 > 易语言源码

易语言取跳转后的网址源码

时间:2019-10-03 11:34:12   作者:ColdOx   评论:0

  如果一个网址做了跳转,想取跳转后的地址可以用这个方法,比如网址:https://www.baidu.com/link?url=Fk4kPtoGRbXsZXVlPBkp2q-Fcw3xNOvee7qL8ahsG9yNYjNihUm1qMMDp3OI4Vcn&wd=&eqid=ea73b35c0002f151000000025d956cf3

跳转后的真实地址就是:www.lenniu.com 用网页_访问的方法得不到地址,访问_取网址也得到的是baidu.com 用下面这个方法就可以得到:www.lenniu.com


-------------------------------

.版本 2


.子程序 取跳转后的网址, 文本型
.参数 地址, 文本型
.局部变量 http, 对象
.局部变量 p, 变体型

.如果真 (http.创建 (“WinHttp.WinHttpRequest.5.1”, ))
    http.写属性 (“Option”, 6, 0)
    http.方法 (“SetTimeouts”, 5000, 5000, 10000, 5000)
    http.方法 (“open”, “GET”, 地址, 假)
    http.方法 (“setRequestHeader”, “User-Agent”, “Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)”)
    http.方法 (“setRequestHeader”, “Accept-Language”, “zh-cn”)
    http.方法 (“setRequestHeader”, “Connection”, “Keep-Alive”)
    http.方法 (“setRequestHeader”, “Accept”, “image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, */*”)
    http.方法 (“send”, )
    p = http.读属性 (“GetResponseHeader”, “Location”)
    返回 (p.取文本 ())

.如果真结束
返回 (“”)

标签:网址  语言  跳转  源码  
上一篇:没有了
下一篇:查看本地Wifi密码工具源码
相关评论

本栏最新更新

本栏推荐

阅读排行

Copyright © 2015-2019 QQ:10004820

  豫ICP备19005080号